OpenFIPI 2.0

Все задания взяты из открытого банка заданий ФИПИ

На текущий момент есть ответы в 1960 заданиях из 3117 (актуальных)

Показаны задания 1,371 - 1,380 из 1,565
# Номер Актуальное Ответ Обновлено
A89B22 12 True False 08.08.2021 22:52:14

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

Цикл

ПОКА  условие 

         последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

     ТО команда1

     ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

 

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 71 идущих подряд цифр 6? В ответе запишите полученную строку.

 

НАЧАЛО

ПОКА  нашлось (5555)  ИЛИ нашлось (6666) 

         ЕСЛИ  нашлось (5555) 

              ТО заменить (5555, 66)

              ИНАЧЕ заменить (6666, 55)

         КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

 

D28B22 16 True True 08.08.2021 22:52:05

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик

Python

DECLARE SUB F(n)

SUB F(n)

  IF n > 2 THEN

    PRINT n

    F(n - 3)

    F(n  1)

  END IF

END SUB

def F(n):

    if n > 2:

        print(n)

        F(n - 3)

        F(n  1)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 2 то

    вывод n, нс

    F(n - 3)

    F(n  1)

  все

кон

procedure F(n: integer);

begin

  if n > 2 then begin

    writeln(n);

    F(n - 3);

    F(n  1)

  end

end;

Си

void F(int n) {

  if (n > 2) {

    printf("%d\n", n);

    F(n - 3);

    F(n  1);

  }

}

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(7)?

71712F 23 True False 08.08.2021 22:51:44

Исполнитель Б16 преобразует число, записанное на экране.

У исполнителя есть три команды, которым присвоены номера:

1.     Прибавить 1

2.     Прибавить 2

3.     Умножить на 2

Первая из них увеличивает число на экране на 1, вторая увеличивает его на 2, третья умножает его на 2.

Программа для исполнителя Б16  это последовательность команд.

Сколько существует таких программ, которые исходное число 4 преобразуют в число 16, и при этом траектория вычислений программы содержит число 11?

Траектория вычислений программы  это последовательность результатов выполнения всех команд программы. Например, для программы 132 при исходном числе 7 траектория будет состоять из чисел 8, 16, 18.

3D151D 12 True False 08.08.2021 22:51:15

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

Цикл

ПОКА  условие 

         последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

     ТО команда1

     ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

 

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 71 идущих подряд цифр 8? В ответе запишите полученную строку.

 

НАЧАЛО

ПОКА  нашлось (2222)  ИЛИ нашлось (8888) 

         ЕСЛИ  нашлось (2222) 

              ТО заменить (2222, 88)

              ИНАЧЕ заменить (8888, 22)

         КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

 

642814 15 True True 08.08.2021 22:51:11

Обозначим через m&n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14&5 = 11102&01012 = 01002 = 4.

Для какого наименьшего неотрицательного целого числа А формула

x&39 = 0 \/ (x&41 = 0 → x&А ≠ 0)

тождественно истинна (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

5EF31A 2 True True 08.08.2021 22:50:58

Логическая функция F задаётся выражением y /\ ¬w /\ (¬x \/ z).

На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F истинна.

Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z.

 

Перем. 1

Перем. 2

Перем. 3

Перем. 4

Функция

???

???

???

???

F

0

0

0

1

1

1

0

0

1

1

1

0

1

1

1

 

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала  буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.) Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Пример. Если бы функция была задана выражением ¬x \/ y, зависящим от двух переменных: x и y, и был приведён фрагмент её таблицы истинности, содержащий все наборы аргументов, при которых функция F истинна.

 

Перем. 1

Перем. 2

Функция

???

???

F

0

0

1

1

0

1

1

1

1

 

Тогда первому столбцу соответствовала бы переменная y, а второму столбцу  переменная x. В ответе следовало бы написать: yx.

B04912 8 True True 08.08.2021 22:50:54

Вася составляет 5-буквенные слова, в которых встречаются только буквы И, К, Л, М, причём буква И появляется ровно 1 раз.  Каждая из других допустимых букв может встречаться в слове любое количество раз или
не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

565AB8 11 True False 08.08.2021 22:50:03

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 9 символов. Из соображений информационной безопасности каждый пароль должен содержать хотя бы одну десятичную цифру, как прописные, так и строчные латинские буквы, а также не менее одного символа из 6-символьного набора: «&», «#», «$», «*», «!», «@».
В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей.

Для хранения сведений о 30 пользователях потребовалось 750 байт. Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число  количество байт.

Примечание: В латинском алфавите 26 букв.

5A36B3 1 True True 08.08.2021 22:49:58

На рисунке справа схема дорог Н-ского района изображена в виде графа;  в таблице слева содержатся сведения о длинах этих дорог (в километрах).

 

 

П1

П2

П3

П4

П5

П6

П1

 

10

 

 

8

5

П2

10

 

 

20

12

 

П3

 

 

 

4

 

 

П4

 

20

4

 

15

 

П5

8

12

 

15

 

7

П6

5

 

 

 

7

 

 

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова длина дороги из пункта Б в пункт В. В ответе запишите целое число  так, как оно указано в таблице.

C51379 1 True True 08.08.2021 22:49:17

На рисунке справа схема дорог Н-ского района изображена в виде графа; 
в таблице слева содержатся сведения о длинах этих дорог (в километрах).

 

 

П1

П2

П3

П4

П5

П6

П1

 

10

 

 

14

19

П2

10

 

 

6

16

 

П3

 

 

 

13

 

 

П4

 

6

13

 

12

 

П5

14

16

 

12

 

17

П6

19

 

 

 

17

 

undefined

 

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова длина дороги из пункта В
в пункт Г. В ответе запишите целое число  так, как оно указано в таблице.