OpenFIPI 2.0

Все задания взяты из открытого банка заданий ФИПИ

На текущий момент есть ответы в 1960 заданиях из 3117 (актуальных)

Показаны задания 1,331 - 1,340 из 1,565
# Номер Актуальное Ответ Обновлено
D9948E 8 True False 08.08.2021 23:10:01

Вася составляет 5-буквенные слова, в которых встречаются только буквы Ж, З, И, причём буква Ж появляется ровно 1 раз.  Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем. Словом считается любая допустимая последовательность букв,
не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

3B703B 14 True False 08.08.2021 23:09:29

Значение арифметического выражения: 922 + 366 – 9 – записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?

C90539 16 True False 08.08.2021 23:09:16

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик

Python

DECLARE SUB F(n)

SUB F(n)

  IF n > 1 THEN

    PRINT n

    F(n - 3)

    F(n  4)

  END IF

END SUB

def F(n):

    if n > 1:

        print(n)

        F(n - 3)

        F(n  4)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 1 то

    вывод n, нс

    F(n - 3)

    F(n  4)

  все

кон

procedure F(n: integer);

begin

  if n > 1 then begin

    writeln(n);

    F(n - 3);

    F(n  4)

  end

end;

Си

void F(int n) {

  if (n > 1) {

    printf("%d\n", n);

    F(n - 3);

    F(n  4);

  }

}

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(10)?

B2DF39 2 True True 08.08.2021 23:09:00

Логическая функция F задаётся выражением x /\ ¬y /\ (¬z \/ w).

На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F истинна.

Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z.

 

Перем. 1

Перем. 2

Перем. 3

Перем. 4

Функция

???

???

???

???

F

0

0

1

0

1

0

0

1

1

1

1

0

1

1

1

 

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала  буква, соответствующая первому столбцу; затем  буква, соответствующая второму столбцу, и т.д.) Буквы
в ответе пишите подряд, никаких разделителей между буквами ставить
не нужно.

Пример. Если бы функция была задана выражением ¬x \/ y, зависящим
от двух переменных: x и y, и был приведён фрагмент её таблицы истинности, содержащий все наборы аргументов, при которых функция F истинна.

 

Перем. 1

Перем. 2

Функция

???

???

F

0

0

1

1

0

1

1

1

1

 

Тогда первому столбцу соответствовала бы переменная y, а второму столбцу  переменная x. В ответе следовало бы написать: yx.

0FAA38 1 True True 08.08.2021 23:08:51

На рисунке справа схема дорог Н-ского района изображена в виде графа;  в таблице слева содержатся сведения о длинах этих дорог (в километрах).

 

 

П1

П2

П3

П4

П5

П6

П1

 

 

7

12

13

15

П2

 

 

 

 

 

4

П3

7

 

 

 

5

 

П4

12

 

 

 

10

20

П5

13

 

5

10

 

 

П6

15

4

 

20

 

 

 

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова длина дороги из пункта Б в пункт В. В ответе запишите целое число  так, как оно указано в таблице.

4EFB34 11 True False 08.08.2021 23:08:35

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 10 символов. Из соображений информационной безопасности каждый пароль должен содержать хотя бы одну десятичную цифру, как прописные, так и строчные латинские буквы, а также не менее одного символа из 6-символьного набора: «&», «#», «$», «*», «!», «@».
В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей.

Для хранения сведений о 20 пользователях потребовалось 500 байт. Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число  количество байт.

Примечание: В латинском алфавите 26 букв.

3E3B69 15 True True 08.08.2021 23:08:08

Обозначим через m&n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14&5 = 11102&01012 = 01002 = 4.

 

Для какого наименьшего неотрицательного целого числа А формула

x&51 = 0 \/ (x&42 = 0 → x&А ≠ 0)

тождественно истинна (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

AF2C6D 19 True False 08.08.2021 23:07:42

Два игрока, Паша и Валя, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Паша. За один ход игрок может добавить в кучу один камень или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 16 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней.

Игра завершается в тот момент, когда количество камней в куче становится не менее 32. Если при этом в куче оказалось не более 54 камней,
то победителем считается игрок, сделавший последний ход. В противном случае победителем становится его противник. Например, если в куче было 29 камней и Паша удвоит количество камней в куче, то игра закончится
и победителем будет Валя. В начальный момент в куче было S камней,
1 ≤ S ≤ 31.

 

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока  значит описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника.

 

Выполните следующие задания.

1. а) При каких значениях числа S Паша может выиграть в один ход?

Укажите все такие значения и соответствующие ходы Паши.

б) У кого из игроков есть выигрышная стратегия при S = 30, 29, 28?

Опишите выигрышные стратегии для этих случаев.

2. У кого из игроков есть выигрышная стратегия при S = 15, 14? Опишите соответствующие выигрышные стратегии.

3. У кого из игроков есть выигрышная стратегия при S = 13? Постройте дерево всех партий, возможных при этой выигрышной стратегии
(в виде рисунка или таблицы). На рёбрах дерева указывайте, кто делает ход; в узлах  количество камней в позиции.

12A26B 15 True True 08.08.2021 23:07:22

Обозначим через m&n поразрядную конъюнкцию неотрицательных целых чисел m и n. Так, например, 14&5 = 11102&01012 = 01002 = 4.

 

Для какого наименьшего неотрицательного целого числа А формула

x&39 = 0 \/ (x&11 = 0 → x&А ≠ 0)

тождественно истинна (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

19DC64 1 True True 08.08.2021 23:07:18

На рисунке справа схема дорог Н-ского района изображена в виде графа; в таблице слева содержатся сведения о длинах этих дорог (в километрах).

 

 

П1

П2

П3

П4

П5

П6

П1

 

 

 

4

 

 

П2

 

 

7

15

12

6

П3

 

7

 

 

 

5

П4

4

15

 

 

20

 

П5

 

12

 

20

 

10

П6

 

6

5

 

10

 

 

undefined

 

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова длина дороги из пункта Б в пункт В. В ответе запишите целое число  так, как оно указано в таблице.