OpenFIPI 2.0

Все задания взяты из открытого банка заданий ФИПИ

На текущий момент есть ответы в 1960 заданиях из 3117 (актуальных)

Показаны задания 1,481 - 1,490 из 1,565
# Номер Актуальное Ответ Обновлено
1D337E 16 True False 08.08.2021 22:22:58

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  PRINT n,

  IF n >= 3 THEN

    F(n - 1)

    F(n - 3)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 3:

        F(n - 1)

        F(n - 3)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 3 то

    F(n - 1)

    F(n - 3)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 3 then

  begin

    F(n  1);

    F(n - 3)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 3) {

    F(n - 1);

    F(n - 3);

  }

}

Что выведет программа при вызове F(5)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

AD945C 15 True True 08.08.2021 22:22:28

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа А логическое выражение

(¬ДЕЛ(x, А)  ДЕЛ(x, 24))  (¬ДЕЛ(x, 16)  ¬ДЕЛ(x, 24))

тождественно истинно (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

76DE5A 15 True True 08.08.2021 22:22:25

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа А логическое выражение

¬ДЕЛ(x, А)→(ДЕЛ(x, 36)→ ¬ДЕЛ(x, 54))

тождественно истинно (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

6962D9 15 True True 08.08.2021 22:22:20

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наименьшего натурального числа А логическое выражение

(¬ДЕЛ(x, 26) ДЕЛ(x, A))  (ДЕЛ(x, 39) ¬ДЕЛ(x, A))

тождественно истинно (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

127E1B 15 True True 08.08.2021 22:08:53

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наименьшего натурального числа А логическое выражение

(¬ДЕЛ(x, 35) ДЕЛ(x, A))  (ДЕЛ(x, 21) ¬ДЕЛ(x, A))

тождественно истинно (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

6C7D42 15 True True 08.08.2021 22:08:48

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m». Для какого наибольшего натурального числа А, не превышающего 300 логическое выражение

(¬ДЕЛ(x, A)  ДЕЛ(x, 35))  (¬ДЕЛ(x, 21)  ¬ДЕЛ(x, 35))

тождественно истинно (т.е. принимает значение 1 при любом неотрицательном целом значении переменной х)?

FFB7CD 11 True True 08.08.2021 22:08:29

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 10 символов и содержащий только символы из 26-символьного набора прописных латинских букв. В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей.

Для хранения сведений о 20 пользователях потребовалось 400 байт. Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число  количество байт.

8E1D88 8 True True 08.08.2021 22:08:10

Игорь составляет таблицу кодовых слов для передачи сообщений, каждому сообщению соответствует своё кодовое слово. В качестве кодовых слов Игорь использует 4-буквенные слова, в которых есть только буквы К, Р, А, Н, причём буква К появляется ровно 1 раз.  Каждая из других допустимых букв может встречаться в кодовом слове любое количество раз или не встречаться совсем. Сколько различных кодовых слов может использовать Игорь?

AF908A 23 True False 08.08.2021 22:07:44

Исполнитель Плюс преобразует число на экране.

У исполнителя есть две команды, которым присвоены номера:

1. Прибавить 2

2. Прибавить 4

Первая команда увеличивает число на экране на 2, вторая увеличивает это число на 4. Программа для исполнителя Плюс  это последовательность команд.

Сколько существует программ, которые число 9 преобразуют в число 25?

5DFD89 14 True False 08.08.2021 22:07:31

Сколько значащих нулей содержится в десятичной записи значения выражения:
10010  105 + 10?