OpenFIPI 2.0

Все задания взяты из открытого банка заданий ФИПИ

На текущий момент есть ответы в 1960 заданиях из 3117 (актуальных)

Показаны задания 2,911 - 2,920 из 3,117
# Номер Актуальное Ответ Обновлено
2DD1CA 16 True True 08.08.2021 22:58:14

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик

Python

DECLARE SUB F(n)

SUB F(n)

  IF n > 1 THEN

    PRINT n

    F(n - 3)

    F(n  5)

  END IF

END SUB

def F(n):

    if n > 1:

        print(n)

        F(n - 3)

        F(n  5)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 1 то

    вывод n, нс

    F(n - 3)

    F(n  5)

  все

кон

procedure F(n: integer);

begin

  if n > 1 then begin

    writeln(n);

    F(n - 3);

    F(n  5)

  end

end;

Си

void F(int n) {

  if (n > 1) {

    printf("%d\n", n);

    F(n - 3);

    F(n  5);

  }

}

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(10)?

EE1EAF 11 True False 08.08.2021 22:57:14

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 9 символов. Из соображений информационной безопасности каждый пароль должен содержать хотя бы одну десятичную цифру, как прописные, так и строчные латинские буквы, а также не менее одного символа из 6-символьного набора: «&», «#», «$», «*», «!», «@».
В базе данных для хранения сведений о каждом пользователе отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей.

Для хранения сведений о 20 пользователях потребовалось 500 байт. Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число  количество байт.

Примечание: В латинском алфавите 26 букв.

2C0AA2 12 True False 08.08.2021 22:56:49

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды

заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

Цикл

ПОКА  условие 

         последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

     ТО команда1

     ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

 

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 69 идущих подряд цифр 8? В ответе запишите полученную строку.

 

НАЧАЛО

ПОКА  нашлось (3333)  ИЛИ нашлось (8888) 

         ЕСЛИ  нашлось (3333) 

              ТО заменить (3333, 88)

              ИНАЧЕ заменить (8888, 33)

         КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

 

EE6A5E 4 True False 08.08.2021 22:56:30

Для кодирования некоторой последовательности, состоящей из букв A, B, C, D, E, F, решили использовать неравномерный двоичный код, удовлетворяющий условию Фано. Для буквы A использовали кодовое слово 0; для буквы B  кодовое слово 10. Какова наименьшая возможная сумма длин всех шести кодовых слов?

Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.

9EC859 16 True True 08.08.2021 22:56:00

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик

Python

DECLARE SUB F(n)

SUB F(n)

  IF n > 2 THEN

    PRINT n

    F(n - 3)

    F(n  4)

  END IF

END SUB

def F(n):

    if n > 2:

        print(n)

        F(n - 3)

        F(n  4)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 2 то

    вывод n, нс

    F(n - 3)

    F(n  4)

  все

кон

procedure F(n: integer);

begin

  if n > 2 then begin

    writeln(n);

    F(n - 3);

    F(n  4)

  end

end;

Си

void F(int n) {

  if (n > 2) {

    printf("%d\n", n);

    F(n - 3);

    F(n  4);

  }

}

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(10)?

50D35E 4 True False 08.08.2021 22:55:01

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г, Д, Е, решили использовать неравномерный двоичный код, удовлетворяющий условию Фано. Для буквы А использовали кодовое слово 1; для буквы Б  кодовое слово 01. Какова наименьшая возможная сумма длин всех шести кодовых слов?

Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.

F05353 14 True False 08.08.2021 22:54:42

Значение арифметического выражения: 926 + 378 – 9 – записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?

7703DE 2 True True 08.08.2021 22:53:41

Логическая функция F задаётся выражением x /\ ¬z /\ (¬y \/ w).

На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F истинна.

Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z.

 

Перем. 1

Перем. 2

Перем. 3

Перем. 4

Функция

???

???

???

???

F

1

0

0

0

1

1

0

0

1

1

1

1

0

1

1

 

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала  буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.) Буквы в ответе пишите подряд, никаких разделителей между буквами ставить
не нужно.

Пример. Если бы функция была задана выражением ¬x \/ y, зависящим
от двух переменных: x и y, и был приведён фрагмент её таблицы истинности, содержащий все наборы аргументов, при которых функция F истинна.

 

Перем. 1

Перем. 2

Функция

???

???

F

0

0

1

1

0

1

1

1

1

 

Тогда первому столбцу соответствовала бы переменная y, а второму столбцу  переменная x. В ответе следовало бы написать: yx.

7D28D5 2 True True 08.08.2021 22:53:31

Логическая функция F задаётся выражением x /\ ¬w /\ (¬z \/ y).

На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F истинна.

Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z.

 

Перем. 1

Перем. 2

Перем. 3

Перем. 4

Функция

???

???

???

???

F

0

0

0

1

1

0

1

0

1

1

1

1

0

1

1

 

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала  буква, соответствующая первому столбцу; затем буква, соответствующая второму столбцу, и т.д.) Буквы в ответе пишите подряд, никаких разделителей между буквами ставить не нужно.

Пример. Если бы функция была задана выражением ¬x \/ y, зависящим от двух переменных: x и y, и был приведён фрагмент её таблицы истинности, содержащий все наборы аргументов, при которых функция F истинна.

 

Перем. 1

Перем. 2

Функция

???

???

F

0

0

1

1

0

1

1

1

1

 

Тогда первому столбцу соответствовала бы переменная y, а второму столбцу  переменная x. В ответе следовало бы написать: yx.

4E2FD7 4 True False 08.08.2021 22:52:54

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г, Д, Е, решили использовать неравномерный двоичный код, удовлетворяющий условию Фано. Для буквы А использовали кодовое слово 0; для буквы Б  кодовое слово 10. Какова наименьшая возможная сумма длин всех шести кодовых слов?

Примечание. Условие Фано означает, что никакое кодовое слово не является началом другого кодового слова. Это обеспечивает возможность однозначной расшифровки закодированных сообщений.