OpenFIPI 2.0

Все задания взяты из открытого банка заданий ФИПИ

На текущий момент есть ответы в 1960 заданиях из 3117 (актуальных)

Показаны задания 2,831 - 2,840 из 3,117
# Номер Актуальное Ответ Обновлено
16886B 8 True False 09.08.2021 11:15:43

Все 3-буквенные слова, составленные из букв У, Ч, Е, Н, И, К, записаны
в алфавитном порядке и пронумерованы, начиная с 1.

Ниже приведено начало списка.

1.  ЕЕЕ

2.  ЕЕИ

3.  ЕЕК

4.  ЕЕН

5.  ЕЕУ

6.  ЕЕЧ

7.  ЕИЕ

Под каким номером в списке идёт первое слово, которое начинается с буквы Ч?

08B86A 2 True True 09.08.2021 11:15:24

Логическая функция F задаётся выражением ¬x \/ y \/ (¬z /\ w).

На рисунке приведён фрагмент таблицы истинности функции F, содержащий все наборы аргументов, при которых функция F ложна.

Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных w, x, y, z.

Переменная 1

Переменная 2

Переменная 3

Переменная 4

Функция

???

???

???

???

F

0

0

1

0

0

0

0

1

1

0

1

0

1

1

0

В ответе напишите буквы w, x, y, z в том порядке, в котором идут соответствующие им столбцы (сначала  буква, соответствующая первому столбцу; затем  буква, соответствующая второму столбцу, и т.д.) Буквы в ответе пишите подряд, никаких разделителей между буквами ставить
не нужно.

Пример. Если бы функция была задана выражением ¬x \/ y, зависящим
от двух переменных: x и y, и был приведён фрагмент её таблицы истинности, содержащий все наборы аргументов, при которых функция истинна.

Переменная 1

Переменная 2

Функция

???

???

F

0

0

1

1

0

1

1

1

1

Тогда первому столбцу соответствовала бы переменная y, а второму
столбцу  переменная x. В ответе следовало бы написать: yx.

F9516C 11 True True 09.08.2021 11:15:20

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы
из 12-символьного набора: А, В, C, D, Е, F, G, H, K, L, M, N. В базе данных для хранения пароля отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит.

Определите объём памяти (в байтах), необходимый для хранения паролей
100 пользователей. В ответе запишите только целое число  количество байт.

 

F1FE67 23 True True 09.08.2021 11:15:06

Исполнитель К17 преобразует число, записанное на экране.

У исполнителя есть три команды, которым присвоены номера:

1.    Прибавить 1

2.    Прибавить 2

3.    Умножить на 2

Первая из них увеличивает число на экране на 1, вторая увеличивает его на 2, третья умножает на 2.

Программа для исполнителя К17  это последовательность команд.

Сколько существует таких программ, которые преобразуют исходное число 3 в число 12 и при этом траектория вычислений программы содержит числа 9
и 11? Траектория должна содержать оба указанных числа.

Траектория вычислений программы  это последовательность результатов выполнения всех команд программы. Например, для программы 132 при исходном числе 7 траектория будет состоять из чисел 8, 16, 18.

6A03E1 1 True True 09.08.2021 11:14:35

На рисунке справа схема дорог Н-ского района изображена в виде графа, в таблице содержатся сведения о протяжённости каждой из этих дорог (в километрах).

 

П1

П2

П3

П4

П5

П6

П7

П1

 

6

7

5

 

 

3

П2

6

 

 

 

 

 

 

П3

7

 

 

11

 

 

12

П4

5

 

11

 

2

4

 

П5

 

 

 

2

 

 

 

П6

 

 

 

4

 

 

 

П7

3

 

12

 

 

 

 

Так как таблицу и схему рисовали независимо друг от друга, то нумерация населённых пунктов в таблице никак не связана с буквенными обозначениями на графе. Определите, какова протяжённость дороги из пункта А в пункт В. В ответе запишите целое число  так, как оно указано
в таблице.

C05392 16 True True 09.08.2021 11:14:22

Ниже на пяти языках программирования записаны две рекурсивные функции (процедуры): F и G.

Бейсик

Python

DECLARE SUB F(n)

DECLARE SUB G(n)

SUB F(n)

  IF n > 0 THEN G(n - 1)

END SUB

 

SUB G(n)

  PRINT "*"

  IF n > 1 THEN F(n - 2)

END SUB

def F(n):

    if n > 0:

        G(n - 1)

 

def G(n):

    print("*")

    if n > 1:

        F(n - 2)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 0 то

    G(n - 1)

  все

кон

 

алг G(цел n)

нач

  вывод "*"

  если n > 1 то

    F(n - 2)

  все

кон

procedure F(n: integer); forward;

procedure G(n: integer); forward;

 

procedure F(n: integer);

begin

  if n > 0 then

    G(n - 1);

end;

 

procedure G(n: integer);

begin

  writeln('*');

  if n > 1 then

    F(n - 2);

end;

Си

void F(int n);
void G(int n);

 

void F(int n){

  if (n > 0)

    G(n - 1);

}

 

void G(int n){

  printf("*");

  if (n > 1)

    F(n - 2);

}

Сколько символов «звёздочка» будет напечатано на экране при выполнении вызова F(13)?

ADE397 19 True False 09.08.2021 11:14:12

Два игрока, Петя и Ваня, играют в следующую игру. Дан набор слов, составленных из букв русского алфавита, при этом ни одно из заданных слов не является началом другого. Слова в этой игре  это просто цепочки букв, они не обязаны быть осмысленными словами русского языка. Игра состоит в том, что игроки составляют слово из набора, приписывая по очереди буквы к концу составляемого слова, т.е. справа. При этом каждое промежуточное слово должно быть началом одного из заданных слов. Выигрывает тот, кто получит одно из заданных слов целиком. Первый ход делает Петя, т.е. Петя пишет первую букву составляемого слова.

Пример. Заданный набор слов: {АНТАРКТИДА, АНТРАЦИТ, АБАРА, АБАЖУР, БББ, БАОБАБ, БАР}.

Первым ходом Петя пишет Б (он мог написать Б или А).

Ваня в ответ дописывает А и получает БА (он мог ещё получить ББ).

Вторым ходом Петя получает БАР и выигрывает.

В заданиях используются следующие понятия. Стратегия игрока  это правило, указывающее игроку ход, который он должен сделать. Описать стратегию игрока  значит описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. Стратегия игрока называется выигрышной, если игрок выигрывает в любой партии, разыгранной в соответствии с этой стратегией, как бы ни играл противник.

Множество всех партий, которые могут получиться при данной стратегии, представляется в виде дерева, это дерево называется деревом всех партий для заданной стратегии. В узлах дерева  позиции игры;
на рёбрах  ходы, которые переводят одну позицию в другую; корень дерева  начальная позиция игры. Дерево всех партий для данной стратегии можно описать с помощью рисунка или таблицы.

Задание 1. а) Укажите, у кого есть выигрышная стратегия при исходном наборе слов {АБВГДАБВГДХ, ДГВБАДГВБА}. Опишите эту стратегию. Сколько различных партий возможно при этой стратегии? Для каждой возможной партии укажите, какое слово будет написано в конце партии.

б) Укажите, у кого есть выигрышная стратегия при исходном наборе слов {ТРИТРИ…ТРИ, РИТАРИТА…РИТА} (в первом слове ТРИ повторено
33 раза, т.е. его длина 99 букв; во втором слове РИТА повторено 44 раза,
т.е. его длина 176 букв). Опишите эту стратегию.

Задание 2. В задании 1а поменяйте местами две буквы в более коротком слове так, чтобы теперь выигрышная стратегия была у другого игрока. Напишите полученный набор слов; опишите выигрышную стратегию. Сколько различных партий возможно при этой стратегии? Для каждой возможной партии укажите, какое слово будет написано в конце партии.

Задание 3. Рассмотрим набор слов {СОЛНЦЕ, СОВА, СОВЕТ, ТРАВА, ТРАССА, ТРАНСПОРТ}. У кого из игроков есть выигрышная стратегия для этого набора? Приведите в виде рисунка или таблицы дерево всех партий, возможных при этой стратегии.

5D3C98 11 True True 09.08.2021 11:14:05

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы
из 8-символьного набора: А, В, C, D, Е, F, G, H. В базе данных для хранения пароля отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит.

Определите объём памяти (в байтах), необходимый для хранения паролей 100 пользователей. В ответе запишите только целое число  количество байт.

 

285C96 11 True False 09.08.2021 11:14:02

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы
из 8-символьного набора: А, В, C, D, Е, F, G, H. В базе данных для хранения каждого пароля отведено одинаковое и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего отведено 24 байт на одного пользователя.

Определите объём памяти (в байтах), необходимый для хранения данных
о 200 пользователях. В ответе запишите только целое число  количество байт.

 

D6A8C9 15 True True 09.08.2021 11:13:32

На числовой прямой даны два отрезка: B = [133; 175] и C = [140; 199]. Укажите наименьшую возможную длину такого отрезка A, что формула

( ¬ (x  B)) → (((x  C) /\ ¬(x  A)) → (x  B))

истинна, т.е. принимает значение 1 при любом значении переменной х.