OpenFIPI 2.0

Все задания взяты из открытого банка заданий ФИПИ

На текущий момент есть ответы в 2344 заданиях из 3234 (актуальных)

Показаны задания 3,161 - 3,170 из 3,234
# Номер Актуальное Ответ Обновлено
1FE58A 11 True True 08.08.2021 22:07:15

При регистрации в компьютерной системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы
из 12-символьного набора: А, В, C, D, Е, F, G, H, K, L, M, N. В базе данных для хранения сведений о каждом пользователе отведено одинаковое
и минимально возможное целое число байт. При этом используют посимвольное кодирование паролей, все символы кодируют одинаковым
и минимально возможным количеством бит. Кроме собственно пароля, для каждого пользователя в системе хранятся дополнительные сведения, для чего выделено целое число байт; это число одно и то же для всех пользователей.

Для хранения сведений о 50 пользователях потребовалось 1000 байт. Сколько байт выделено для хранения дополнительных сведений об одном пользователе? В ответе запишите только целое число  количество байт.

 

7BCE8E 14 True True 08.08.2021 22:07:02

Сколько единиц содержится в двоичной записи значения выражения:
416 + 236  16?

860E33 12 True False 08.08.2021 22:06:47

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды, в обеих командах v и w обозначают цепочки цифр.

А) заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку.

Б) нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

Цикл

ПОКА  условие 

         последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

     ТО команда1

     ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

 

Какая строка получится в результате применения приведённой ниже программы к строке, состоящей из 92 идущих подряд цифр 8? В ответе запишите полученную строку.

 

НАЧАЛО

ПОКА  нашлось (222)  ИЛИ нашлось (888) 

         ЕСЛИ  нашлось (222) 

              ТО заменить (222, 8)

              ИНАЧЕ заменить (888, 2)

         КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

 

CEF635 15 True True 08.08.2021 22:06:01

На числовой прямой даны два отрезка: D = [15; 40] и C = [21; 63]. Укажите наименьшую возможную длину такого отрезка A, что формула

(x  D) → ((¬(x  C) /\ ¬(x  A)) → ¬(x  D))

истинна (то есть принимает значение 1 при любом значении переменной х).

8ED26F 19 True False 08.08.2021 22:05:07

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в кучу один камень или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 16 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней.

Игра завершается в тот момент, когда количество камней в куче становится не менее 25. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 25 или больше камней.

В начальный момент в куче было S камней, 1 ≤ S ≤ 24.

 

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока  значит описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника.

 

Выполните следующие задания. Во всех случаях обосновывайте свой ответ.

Задание 1

а)     Укажите все такие значения числа S, при которых Петя может выиграть в один ход, и соответствующие выигрывающие ходы. Если при некотором значении S Петя может выиграть несколькими способами, достаточно указать один выигрывающий ход.

б)    Укажите такое значение S, при котором Петя не может выиграть за один ход, но при любом ходе Пети Ваня может выиграть своим первым ходом. Опишите выигрышную стратегию Вани.

Задание 2

Укажите два таких значения S, при которых у Пети есть выигрышная стратегия, причём одновременно выполнены два условия:

 Петя не может выиграть за один ход;

 Петя может выиграть своим вторым ходом независимо от того, как будет ходить Ваня.

Для каждого указанного значения S опишите выигрышную стратегию Пети.

Задание 3

Укажите значение S, при котором:

 у Вани есть выигрышная стратегия, позволяющая ему выиграть первым или вторым ходом при любой игре Пети;

 у Вани нет стратегии, которая позволит ему гарантированно выиграть
первым ходом.

Для указанного значения S опишите выигрышную стратегию Вани. Постройте дерево всех партий, возможных при этой выигрышной стратегии Вани (в виде рисунка или таблицы). На рёбрах дерева указывайте ходы, в узлах указывайте позиции.

 

2D8E6D 8 True True 08.08.2021 22:04:04

Игорь составляет таблицу кодовых слов для передачи сообщений, каждому сообщению соответствует своё кодовое слово. В качестве кодовых слов Игорь использует 4-буквенные слова, в которых есть только буквы С, Т, О, Л, причём буква С появляется ровно 1 раз.  Каждая из других допустимых букв может встречаться в кодовом слове любое количество раз или
не встречаться совсем. Сколько различных кодовых слов может использовать Игорь?

0D4861 16 True False 08.08.2021 22:03:53

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  PRINT n,

  IF n >= 5 THEN

    F(n - 2)

    F(n - 1)

    F(n - 2)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 5:

        F(n - 2)

        F(n - 1)

        F(n - 2)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 5 то

    F(n - 2)

    F(n - 1)

    F(n - 2)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 5 then

  begin

    F(n - 2);

    F(n - 1);

    F(n - 2)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 5) {

    F(n - 2);

    F(n - 1);

    F(n - 2);

  }

}

Что выведет программа при вызове F(6)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

478F68 16 True False 08.08.2021 22:03:33

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  print n,

  IF n >= 7 THEN

    F(n - 3)

    F(n - 1)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 7:

        F(n - 3)

        F(n - 1)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 7 то

    F(n - 3)

    F(n - 1)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 7 then

  begin

    F(n  3);

    F(n - 1)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 7) {

    F(n - 3);

    F(n - 1);

  }

}

Что выведет программа при вызове F(9)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

30A7E4 19 True False 08.08.2021 21:56:00

Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежат две кучи камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок может добавить в одну из куч (по своему выбору) один камень или увеличить количество камней в куче в два раза. Например, пусть в одной куче 10 камней, а в другой 7 камней; такую позицию в игре будем обозначать (10, 7). Тогда за один ход можно получить любую из четырёх позиций:
(11, 7), (20, 7), (10, 8), (10, 14). Для того чтобы делать ходы, у каждого игрока есть неограниченное количество камней.

 

Игра завершается в тот момент, когда суммарное количество камней
в кучах становится не менее 55. Победителем считается игрок, сделавший последний ход, т.е. первым получивший такую позицию, что в кучах всего будет 55 или больше камней.

 

Будем говорить, что игрок имеет выигрышную стратегию, если он может выиграть при любых ходах противника. Описать стратегию игрока  значит описать, какой ход он должен сделать в любой ситуации, которая ему может встретиться при различной игре противника. Например, при начальных позициях (4, 26) и (5, 25) выигрышная стратегия есть у Пети. Чтобы выиграть, ему достаточно удвоить количество камней во второй куче.

 

Задание 1. Для каждой из начальных позиций (4, 25), (6, 24) укажите, кто из игроков имеет выигрышную стратегию. В каждом случае опишите выигрышную стратегию; объясните, почему эта стратегия ведёт
к выигрышу, и укажите, какое наибольшее количество ходов может потребоваться победителю для выигрыша при этой стратегии.

 

Задание 2. Для каждой из начальных позиций (4, 24), (5, 24), (6, 23) укажите, кто из игроков имеет выигрышную стратегию. В каждом случае опишите выигрышную стратегию; объясните, почему эта стратегия ведёт
к выигрышу, и укажите, какое наибольшее количество ходов может потребоваться победителю для выигрыша при этой стратегии.

 

Задание 3. Для начальной позиции (5, 23) укажите, кто из игроков имеет выигрышную стратегию. Опишите выигрышную стратегию; объясните, почему эта стратегия ведёт к выигрышу, и укажите, какое наибольшее количество ходов может потребоваться победителю для выигрыша при этой стратегии. Постройте дерево всех партий, возможных при указанной Вами выигрышной стратегии. Представьте дерево в виде рисунка или таблицы.

 

AD8BE5 14 True True 08.08.2021 21:55:23

Значение арифметического выражения: 98 + 35 9  записали в системе счисления с основанием 3. Сколько цифр «2» содержится в этой записи?