OpenFIPI 2.0

1152

6

oge_F81EBB

Напишите программу подсчёта количества элементов последовательности натуральных чисел, запись которых в восьмеричной системе счисления трёхзначна и оканчивается на цифру 6. В ответе запишите количество искомых элементов.

На вход программе сначала подаётся количество элементов последовательности N (1 ≤ N ≤ 1000), затем каждый элемент последовательности в отдельной строке.

Программа должна напечатать только одно число – количество искомых элементов последовательности.

 

Пример работы программы

Входные данные

Выходные данные

5

38

166

478

510

582

3

 

n = int(input())
count = 0
for _ in range(n):
    num = int(input())
   # Переводим число в восьмеричную систему
   octal = oct(num)[2:] # [2:] убирает префикс '0o'
   # Проверяем, что число трёхзначное и оканчивается на '6'
   if len(octal) == 3 and octal[-1] == '6':
      count += 1
print(count)

n = int(input())
count = 0
for _ in range(n):
    num = int(input())
   # Переводим число в восьмеричную систему
   octal = oct(num)[2:] # [2:] убирает префикс '0o'
   # Проверяем, что число трёхзначное и оканчивается на '6'
   if len(octal) == 3 and octal[-1] == '6':
      count += 1
print(count)

Просмотреть отправленные ответы oge_F81EBB