OpenFIPI 2.0

Редактировать oge_F0B088

Ниже приведена программа, записанная на пяти языках программирования.

Алгоритмический язык

Паскаль

алг

нач

цел s, t, A

ввод s

ввод t

ввод A

если s > A или t > 12

  то вывод "YES"

  иначе вывод "NO"

все

кон

var s, t, A: integer;

begin

 readln(s);

 readln(t);

 readln(A);

 if (s > A) or (t > 12)

  then

    writeln("YES")

  else

    writeln("NO")

end.

Бейсик

Python

DIM s, t, A AS INTEGER

INPUT s

INPUT t

INPUT A

IF s > A OR t > 12 THEN

  PRINT "YES"

ELSE

  PRINT "NO"

ENDIF

s = int(input())

t = int(input())

A = int(input())

if (s > A) or (t > 12):

    print("YES")

else:

    print("NO")

C++

#include <iostream>

using namespace std;

 

int main() {

   int s, t, A;

   cin >> s;

   cin >> t;

   cin >> A;

   if (s > A || t > 12)

     cout << "YES" << endl;

   else

     cout << "NO" << endl;

   return 0;

 }

 

Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:

(13, 2); (11, 12); (12, 12); (2, 2); (10, 10); (6, 5); (2, 8); (9, 10); (1, 13).

Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «NO» шесть раз.

Комментарии