OpenFIPI 2.0

1152

6

oge_D9A7E1

Напишите программу, которая в последовательности натуральных десятичных чисел определяет наибольший элемент, запись которого в системе счисления с основанием 9 оканчивается цифрой 1. Если среди входных данных таких элементов нет, программа должна вывести «NO».

Программа получает на вход натуральные десятичные числа, не превышающие 30 000, каждое в отдельной строке. Количество введённых чисел неизвестно, их последовательность заканчивается числом 0 (0 – признак окончания ввода, в последовательность не входит).

Программа должна вывести одно десятичное число – наибольший элемент последовательности, запись которого в 9-ричной системе счисления оканчивается цифрой 1, или «NO», если среди входных данных таких элементов нет.

 

Пример работы программы

Входные данные

Выходные данные

10

9

11

91

28

0

91

 

maxi = 0
a = 1
while a != 0:
    a = int(input())
    if a % 9 == 1 and a>maxi:
        maxi = a
if maxi != 0:
    print(maxi)
else:
    print('NO')

maxi = 0
a = 1
while a != 0:
    a = int(input())
    if a % 9 == 1 and a>maxi:
        maxi = a
if maxi != 0:
    print(maxi)
else:
    print('NO')

Просмотреть отправленные ответы oge_D9A7E1