OpenFIPI 2.0
106
6
oge_B718B3
Ниже приведена программа, записанная на пяти языках программирования.
|
Алгоритмический язык |
Паскаль |
|
алг нач цел s, t, A ввод s ввод t ввод A если s > 10 или t > А то вывод "YES" иначе вывод "NO" все кон |
var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > 10) or (t > А) then writeln("YES") else writeln("NO") end. |
|
Бейсик |
Python |
|
DIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > 10 OR t > А THEN PRINT "YES" ELSE PRINT "NO" ENDIF |
s = int(input()) t = int(input()) A = int(input()) if (s > 10) or (t > А): print("YES") else: print("NO") |
|
C++ |
|
|
#include <iostream> using namespace std;
int main(){ int s, t, A; cin >> s; cin >> t; cin >> A; if (s > 10 || t > А) cout << "YES" << endl; else cout << "NO" << endl; return 0; } |
|
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(1, 2); (11, 2); (1, 12); (11, 12); ( –11, –12); ( –11, 12); ( –12, 11); (10, 10); (10, 5).
Укажите количество целых значений параметра А, при которых для указанных входных данных программа напечатает «NO» три раза.
5
Просмотреть отправленные ответы oge_B718B3