OpenFIPI 2.0

1152

6

oge_8A188D

Напишите программу подсчёта количества элементов последовательности натуральных чисел, запись которых в шестнадцатеричной системе счисления трёхзначна и оканчивается на цифру 8. В ответе запишите количество искомых элементов.

Программа получает на вход натуральные числа. Количество введённых чисел неизвестно, но не превышает 1000. Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Программа должна напечатать только одно число – количество искомых элементов последовательности.

 

Пример работы программы

Входные данные

Выходные данные

168

280

888

952

4120

0

3

 

a = int(input())
k=0
while a!=0:
    b=hex(a)[2:]
    if len(b)==3 and b[-1]=="8":
        k+=1
    a = int(input())
print(k)

a = int(input())
k=0
while a!=0:
    b=hex(a)[2:]
    if len(b)==3 and b[-1]=="8":
        k+=1
    a = int(input())
print(k)

Просмотреть отправленные ответы oge_8A188D