OpenFIPI 2.0

1152

6

oge_7B0834

Напишите программу подсчёта количества элементов последовательности натуральных чисел, запись которых в шестнадцатеричной системе счисления трёхзначна и оканчивается на цифру 6. В ответе запишите количество искомых элементов.

Программа получает на вход натуральные числа. Количество введённых чисел неизвестно, но не превышает 1000. Последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

Программа должна напечатать только одно число – количество искомых элементов последовательности.

 

Пример работы программы

Входные данные

Выходные данные

166

278

886

950

4118

0

3

 

a=int(input())
count=0
while a!=0:
    if 16**2<=a<16**3 and a%16==6:
        count+=1
    a=int(input())
print(count)

a=int(input())
count=0
while a!=0:
    if 16**2<=a<16**3 and a%16==6:
        count+=1
    a=int(input())
print(count)

Просмотреть отправленные ответы oge_7B0834