OpenFIPI 2.0

1152

6

oge_7AC43D

Напишите программу подсчёта количества элементов последовательности натуральных чисел, запись которых в восьмеричной системе счисления четырёхзначна и оканчивается на цифру 2. В ответе запишите количество искомых элементов.

На вход программе сначала подаётся количество элементов последовательности N (1 ≤ N ≤ 1000), затем каждый элемент последовательности в отдельной строке.

Программа должна напечатать только одно число – количество искомых элементов последовательности.

 

Пример работы программы

Входные данные

Выходные данные

5

482

554

890

3026

4122

3

 

n = int(input())
count = 0
for _ in range(n):
    x = int(input())
    x2 = oct(x)[2:]
    if len(x2) == 4 and x2.endswith('2'):
         count += 1
print(count)

Просмотреть отправленные ответы oge_7AC43D