OpenFIPI 2.0
106
6
oge_1B7480
Ниже приведена программа, записанная на пяти языках программирования.
Алгоритмический язык |
Паскаль |
алг нач цел s, t, A ввод s ввод t ввод A если s > А или t > 11 то вывод "YES" иначе вывод "NO" все кон |
var s, t, A: integer; begin readln(s); readln(t); readln(A); if (s > А) or (t > 11) then writeln("YES") else writeln("NO") end. |
Бейсик |
Python |
DIM s, t, A AS INTEGER INPUT s INPUT t INPUT A IF s > А OR t > 11 THEN PRINT "YES" ELSE PRINT "NO" ENDIF |
s = int(input()) t = int(input()) A = int(input()) if (s > А) or (t > 11): print("YES") else: print("NO") |
C++ |
|
#include <iostream> using namespace std;
int main(){ int s, t, A; cin >> s; cin >> t; cin >> A; if (s > А || t > 11) cout << "YES" << endl; else cout << "NO" << endl; return 0; } |
Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары чисел:
(–9, 11); (2, 7); (5, 12); (2, –2); (7, –9); (12, 6); (9, –1); (7, 11); (11, –5).
Укажите наибольшее целое значение параметра А, при котором для указанных входных данных программа напечатает «YES» три раза.
Просмотреть отправленные ответы oge_1B7480