OpenFIPI 2.0

1152

6

oge_046587

Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.

Количество чисел не превышает 1000. Введённые числа не превышают 30 000.

Программа должна вывести одно число  максимальное число, кратное 4.

 

Пример работы программы:

Входные данные

Выходные данные

3
8
16
11

16

 

max_num = -30000

n = int(input())

for _ in range(n):

    num = int(input())

   if num % 4 == 0 and num >= max_num:

      max_num = num

print(max_num)

Просмотреть отправленные ответы oge_046587