OpenFIPI 2.0

1152

6

oge_014503

Напишите программу, которая в последовательности натуральных десятичных чисел определяет среднее арифметическое элементов, запись которых в системе счисления с основанием 5 оканчивается нечётной цифрой. Если среди входных данных таких элементов нет, программа должна вывести «NO».

Программа получает на вход натуральные десятичные числа, не превышающие 30 000, каждое в отдельной строке. Количество введённых чисел неизвестно, их последовательность заканчивается числом 0 (0 – признак окончания ввода, в последовательность не входит).

Программа должна вывести одно число – среднее арифметическое десятичных чисел (элементов последовательности), запись которых в системе счисления с основанием 5 оканчивается нечётной цифрой, или «NO», если среди входных данных таких элементов нет.

Пример работы программы

Входные данные

Выходные данные

12

15

10

71

50

11

0

41

 

a=2
s=0
k=0
while True:
    if a==0:
         break
    a=int(input())
    if (a%5)%2!=0:
        s+=a
        k+=1
if k!=0:
    print(s/k)
else:
    print("NO")

a=2
s=0
k=0
while True:
    if a==0:
         break
    a=int(input())
    if (a%5)%2!=0:
        s+=a
        k+=1
if k!=0:
    print(s/k)
else:
    print("NO")

Просмотреть отправленные ответы oge_014503