OpenFIPI 2.0

16

5

FDDA65

Алгоритм вычисления функций F(n) и G(n), где n – целое число, задан следующими соотношениями:

F(n) = 2 × (G(n – 3) + 8);

G(n) = 2 × n, если n < 10;

G(n) = G(n – 2) + 1, если n ≥ 10.

Чему равно значение выражения F(15548)?

15588

from functools import *
@lru_cache(None)
def f(n):
    return 2*(g(n-3)+8)

from functools import *
@lru_cache(None)
def g(n):
    if n < 10: return 2 * n
    return g(n-2) + 1

for i in range(10,15548): g(i)

print(f(15548))

Просмотреть отправленные ответы FDDA65