OpenFIPI 2.0

8

1

F70AC6

Сколько существует десятичных четырёхзначных чисел, делящихся на 5, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом?

144

from itertools import *

k = 0
for i in product('0123456789', repeat=4):
    i = ''.join(i)
    # i = i.replace('3', '1').replace('5', '1').replace('7', '1')
    if (i[-1] in '05' and i[0] != '0' and len(set(i)) == 4):
        if all(int(i[j]) % 2 != int(i[j + 1]) % 2 for j in range(len(i) - 1)):
            k += 1

print(k)

Просмотреть отправленные ответы F70AC6