OpenFIPI 2.0

Редактировать EDFA07

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик

Python

DECLARE SUB F(n)

SUB F(n)

  IF n > 2 THEN

    PRINT n

    F(n - 2)

    F(n  4)

  END IF

END SUB

def F(n):

    if n > 2:

        print(n)

        F(n - 2)

        F(n  4)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 2 то

    вывод n, нс

    F(n - 2)

    F(n  4)

  все

кон

procedure F(n: integer);

begin

  if n > 2 then begin

    writeln(n);

    F(n - 2);

    F(n  4)

  end

end;

Си

void F(int n) {

  if (n > 2) {

    printf("%d\n", n);

    F(n - 2);

    F(n  4);

  }

}

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(9)?

Комментарии