OpenFIPI 2.0

14

2

DE4AE1

Значение арифметического выражения 7170 + 7100x, где x – целое положительное число, не превышающее 2030, записали в 7-ричной системе счисления. Определите наибольшее значение x, при котором количество нулей в 7-ричной записи числа, являющегося значением данного арифметического выражения, максимально.

В ответе запишите число в десятичной системе счисления.

1715

def to7(x):
    s = []
    while x:
        s.append(x % 7)
        x //= 7
    return s


mx = 0
for x in range(1, 2031):
    a = to7(7**170 + 7**100-x)
    if a.count(0) >= mx:
        mx = a.count(0)
        print(x, mx)

Просмотреть отправленные ответы DE4AE1