OpenFIPI 2.0

8

1

DBBC1E

 

Вася составляет 5-буквенные слова, в которых есть только буквы В, О, Л, К, причём буква В используется в каждом слове ровно 1 раз. Каждая из других допустимых букв может встречаться в слове любое количество раз или не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

 

405

from itertools import *

k = 0
for i in product('ВОЛК', repeat=5):
    i = ''.join(i)
    # print(i)
    if i.count('В') == 1:
        k += 1
print(k)

Просмотреть отправленные ответы DBBC1E