OpenFIPI 2.0

11

1

D70A50

На предприятии каждой изготовленной детали присваивают серийный номер, состоящий из 204 символов. В базе данных каждый серийный номер занимает одинаковое и минимально возможное число байт. При этом используется посимвольное кодирование серийных номеров, все символы кодируются одинаковым и минимально возможным числом бит. Известно, что для хранения 94 523 серийных номеров потребовалось не менее 12 Мбайт памяти. Определите минимально возможную мощность алфавита, используемого для записи серийных номеров. В ответе запишите только целое число.

33

from math import ceil, log

for N in range(1, 1000): # мощность алфавита
    L = 204  # длина
    i = ceil(log(N, 2))  # вес одного символа
    I = ceil(L * i / 8)  # вес серийного номера
    I = I * 94523 / 1024 / 1024
    if I > 12:
        print(N)
        break

Просмотреть отправленные ответы D70A50