OpenFIPI 2.0

15

3

D2CF8C

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наименьшего натурального числа А логическое выражение

(ДЕЛ(x, 3) → ¬ДЕЛ(x, 5)) \/ (x + A ≥ 80)

истинно (т.е. принимает значение 1) при любом целом положительном значении переменной х?

65

def f(x):
    return ((x % 3 == 0) <= (x % 5 != 0)) or (x + a >= 80)


for a in range(1, 100):
    if all(f(x) for x in range(1, 1000)):
        print(a)
        break

Просмотреть отправленные ответы D2CF8C