OpenFIPI 2.0

15

3

CD8ED0

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наименьшего натурального числа А логическое выражение

 

 (ДЕЛ(x, 2) → ¬ДЕЛ(x, 5)) \/ (x + A ≥ 70)

 

истинно (т.е. принимает значение 1) при любом целом положительном значении переменной х?

60

def f(x):
    return ((x % 2 == 0) <= (x % 5 != 0)) or (x + a >= 70)


for a in range(1, 100):
    if all(f(x) for x in range(1, 1000)):
        print(a)
        break

Просмотреть отправленные ответы CD8ED0