OpenFIPI 2.0

12

5

ABF524

Исполнитель Редактор получает на вход строку цифр и преобразовывает её. Редактор может выполнять две команды,
в обеих командах v и w обозначают цепочки цифр.

А)    заменить (v, w).

Эта команда заменяет в строке первое слева вхождение цепочки v на цепочку w. Например, выполнение команды

заменить (111, 27)

преобразует строку 05111150 в строку 0527150.

Если в строке нет вхождений цепочки v, то выполнение команды заменить (v, w) не меняет эту строку.

Б)      нашлось (v).

Эта команда проверяет, встречается ли цепочка v в строке исполнителя Редактор. Если она встречается, то команда возвращает логическое значение «истина», в противном случае возвращает значение «ложь». Строка исполнителя при этом не изменяется.

 

Цикл

ПОКА  условие 

         последовательность команд

КОНЕЦ ПОКА

выполняется, пока условие истинно.

В конструкции

ЕСЛИ  условие

     ТО команда1

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно).

В конструкции

ЕСЛИ  условие

     ТО команда1

     ИНАЧЕ команда2

КОНЕЦ ЕСЛИ

выполняется команда1 (если условие истинно) или команда2 (если условие ложно).

 

Определите количество нулей в строке, получившейся в результате применения приведённой ниже программы к входной строке  1000...00ue152ue153ue151ue150ue154ue154ue154ue154ue154ue154551000...00︸55, т.е. к строке, состоящей из  единицы, за которой следуют 55 нулей подряд.

В ответе запишите только количество нулей в получившейся строке.

 

НАЧАЛО

ПОКА  нашлось (1) 

         ЕСЛИ  нашлось (10) 

              ТО заменить (10, 001)

              ИНАЧЕ  заменить (1, 00)

          КОНЕЦ ЕСЛИ

КОНЕЦ ПОКА

КОНЕЦ

112

s= 55*"0"

while "1" in s:

    if "10" in s:

        s= s.replace("10","001",1)

    else:

        s=s.replace("1","00",1)

print(s)

Просмотреть отправленные ответы ABF524