OpenFIPI 2.0

8

1

921F48

Определите количество девятеричных пятизначных чисел, которые не начинаются с нечётных цифр, не оканчиваются цифрами 1 или 8, а также содержат в своей записи не более одной цифры 3.

18944

alf = '012345678'
n_ch = '01357'
cnt = 0
for s1 in alf:
    for s2 in alf:
        for s3 in alf:
            for s4 in alf:
                for s5 in alf:
                    s = s1 + s2 + s3 + s4 + s5
                    if (s1 not in n_ch and
                        s5 != '8' and
                        s5 != '1' and
                        s.count('3') <= 1):
                        cnt += 1
print(cnt)

Просмотреть отправленные ответы 921F48