OpenFIPI 2.0

8

1

8130D1

Определите количество шестизначных чисел, записанных в шестеричной системе счисления, в записи которых ровно одна цифра 2, при этом никакая нечётная цифра не стоит рядом с цифрой 2.

3700

from itertools import product

k = 0
for i in product('012345', repeat=6):
    i = ''.join(i)
    if i[0] != '0' and i.count('2') == 1:
        i = i.replace('3', '1').replace('5', '1')
        if '12' not in i and '21' not in i:
            k += 1
print(k)

Просмотреть отправленные ответы 8130D1