OpenFIPI 2.0

15

3

771BFe

Для какого наибольшего целого неотрицательного числа А логическое выражение

(2x + y ≠ 110) \/ (x < y) \/ (A < x)

истинно (т.е. принимает значение 1) при любых целых неотрицательных x и y?

36

def f(a, x, y):
    return (2 * x + y != 110) or (x < y) or (a < x)

for a in range(1000, 1, -1):
    if all(f(a, x, y) for x in range(1000) for y in range(1000)):
        print(a)
        break

________________________________

def f(x,y):
    return (2 * x + y != 110) or (x < y) or (a<x)
for  a in range(100,1,-1): #перебор с конца, т.к нужно наибольшее значение
    if all(f(x,y) for x in range(1,1000) for y in range(1,1000)):
        print(a)
        break

Просмотреть отправленные ответы 771BFe