OpenFIPI 2.0

11

1

64B724

На предприятии каждой изготовленной детали присваивают серийный номер, состоящий из 124 символов. В базе данных каждый серийный номер занимает одинаковое и минимально возможное число байт. При этом используется посимвольное кодирование серийных номеров, все символы кодируются одинаковым и минимально возможным числом бит. Известно, что для хранения 124 587 серийных номеров отведено менее 15 Мбайт памяти. Определите максимально возможную мощность алфавита, используемого для записи серийных номеров. В ответе запишите только целое число.

256

from math import ceil, log

for N in range(1000, 0, -1): # мощность алфавита
    L = 124  # длина
    i = ceil(log(N, 2))  # вес одного символа
    I = ceil(L * i / 8)  # вес серийного номера
    I = I * 124587 / 1024 / 1024
    if I < 15:
        print(N)
        break

Просмотреть отправленные ответы 64B724