OpenFIPI 2.0

13

4

580BC7

В терминологии сетей TCP/IP маской сети называют двоичное число, которое показывает, какая часть IP-адреса узла сети относится к адресу сети, а какая – к адресу узла в этой сети. Адрес сети получается в результате применения поразрядной конъюнкции к заданному адресу узла и маске сети.

Сеть задана IP-адресом 172.16.192.0 и маской сети 255.255.192.0.

Сколько в этой сети IP-адресов, для которых количество единиц в двоичной записи IP-адреса не кратно 5?

В ответе укажите только число.

13003

from ipaddress import *
net = ip_network('172.16.192.0/255.255.192.0',0)
ipi = []
for ip in net:
    if bin(int(ip)).count('1')%5!=0:
        ipi.append(ip)
print(len(ipi))

Просмотреть отправленные ответы 580BC7