OpenFIPI 2.0

8

1

547AE3

Вася составляет 4-буквенные слова, в которых встречаются только буквы Д, Е, Ж, З, причём буква Д появляется ровно 1 раз.  Каждая из других допустимых букв может встречаться в слове любое количество раз или
не встречаться совсем. Словом считается любая допустимая последовательность букв, не обязательно осмысленная. Сколько существует таких слов, которые может написать Вася?

108

from itertools import product

k = 0
for i in product('ДЕЖЗ', repeat=4):
    i = ''.join(i)
    if i.count('Д') == 1:
            k += 1
print(k)

Просмотреть отправленные ответы 547AE3