OpenFIPI 2.0

15

3

4CCE43

Обозначим через ДЕЛ(n, m) утверждение «натуральное число n делится без остатка на натуральное число m».

Для какого наименьшего натурального числа А формула 

 (ДЕЛ(x, 3) → ¬ДЕЛ(x, 5)) \/ (x + A ≥ 90)

тождественно истинна (т.е. принимает значение 1) при любом натуральном значении переменной х?

75

def f(x):
    return ((x % 3 == 0) <= (x % 5 != 0)) or (x + a >= 90)

for a in range(1, 1000):
    if all(f(x) for x in range(1, 1000)):
        print(a)
        break

Просмотреть отправленные ответы 4CCE43