OpenFIPI 2.0

Редактировать 478F68

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  print n,

  IF n >= 7 THEN

    F(n - 3)

    F(n - 1)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 7:

        F(n - 3)

        F(n - 1)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 7 то

    F(n - 3)

    F(n - 1)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 7 then

  begin

    F(n  3);

    F(n - 1)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 7) {

    F(n - 3);

    F(n - 1);

  }

}

Что выведет программа при вызове F(9)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

Комментарии