OpenFIPI 2.0

16

5

3eB0F2

Алгоритм вычисления функций F(n) и G(n), где n – целое число, задан следующими соотношениями:

F(n) = 3 × G(n – 3) + 7;

G(n) = n + 2, если n ≤ 20;

G(n) = G(n – 3) + 1, если n > 20.

Чему равно значение выражения F(37811)?

37861

def f(n):
    return 3 * g(n - 3) + 7

from functools import *
@lru_cache()
def g(n):
    if n<= 20: return n + 2
    return g(n - 3) +1
for i in range(20,37811): g(i)
print(f(37811))

Просмотреть отправленные ответы 3eB0F2