OpenFIPI 2.0

Редактировать 2DD1CA

Ниже на пяти языках программирования записан рекурсивный алгоритм F.

Бейсик

Python

DECLARE SUB F(n)

SUB F(n)

  IF n > 1 THEN

    PRINT n

    F(n - 3)

    F(n  5)

  END IF

END SUB

def F(n):

    if n > 1:

        print(n)

        F(n - 3)

        F(n  5)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  если n > 1 то

    вывод n, нс

    F(n - 3)

    F(n  5)

  все

кон

procedure F(n: integer);

begin

  if n > 1 then begin

    writeln(n);

    F(n - 3);

    F(n  5)

  end

end;

Си

void F(int n) {

  if (n > 1) {

    printf("%d\n", n);

    F(n - 3);

    F(n  5);

  }

}

Чему равна сумма напечатанных на экране чисел при выполнении вызова F(10)?

Комментарии