OpenFIPI 2.0

Редактировать 1D337E

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  PRINT n,

  IF n >= 3 THEN

    F(n - 1)

    F(n - 3)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 3:

        F(n - 1)

        F(n - 3)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 3 то

    F(n - 1)

    F(n - 3)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 3 then

  begin

    F(n  1);

    F(n - 3)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 3) {

    F(n - 1);

    F(n - 3);

  }

}

Что выведет программа при вызове F(5)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

Комментарии