OpenFIPI 2.0

16

5

1644D5

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(n) = 1 при n < 3;

F(n) = F(n − 2) − F(n − 1), если n > 2 и при этом n чётно;

F(n) = 2 × F(n − 1) − F(n − 2), если n > 2 и при этом n нечётно.

Чему равно значение функции F(18)?

 

169

f = [0] * 20
for n in range(1, 20):
    if n < 3:
        f[n] = 1
    elif n % 2 == 0:
        f[n] = f[n - 2] - f[n - 1]
    else:
        f[n] = 2 * f[n - 1] - f[n - 2]
print(f[18])

Просмотреть отправленные ответы 1644D5