OpenFIPI 2.0

8

1

138B70

Определите количество пятизначных чисел, записанных в восьмеричной системе счисления, в записи которых ровно одна цифра 6, при этом никакая нечётная цифра не стоит рядом с цифрой 6.

2961

from itertools import product

k = 0
for item in product('01234567', repeat=5):
    item = ''.join(item).replace('3', '1').replace('5', '1').replace('7', '1')
    if item.count('6') == 1 and item[0] != '0' and '16' not in item and '61' not in item:
        k += 1
print(k)

print(1 * 3 * 7 * 7 * 7 + 2 * 1 * 3 * 7 * 7 + 6 * 3 * 1 * 3 * 7 * 2 + 6 * 7 * 7 * 3 * 1)

Просмотреть отправленные ответы 138B70