OpenFIPI 2.0

14

2

0FEA2F

Значение арифметического выражения 3100x, где x – целое положительное число, не превышающее 2030, записали в троичной системе счисления. Определите наибольшее значение x, при котором в троичной записи числа, являющегося значением данного арифметического выражения, содержится ровно один нуль.

В ответе запишите число в десятичной системе счисления.

1823

for x in range(2030,1,-1): #перебор с конца,т.к нужен наибольший х
    a = 3**100 - x
    k = 0
    while a>0:
        if a%3==0: k+=1
        a = a//3
    if k == 1:
        print(x)
        break

Просмотреть отправленные ответы 0FEA2F