OpenFIPI 2.0

0D4861

Ниже на пяти языках программирования записана рекурсивная функция (процедура) F.

Бейсик

Python

SUB F(n)

  PRINT n,

  IF n >= 5 THEN

    F(n - 2)

    F(n - 1)

    F(n - 2)

  END IF

END SUB

def F(n):

    print(n, end='')

    if n >= 5:

        F(n - 2)

        F(n - 1)

        F(n - 2)

 

Алгоритмический язык

Паскаль

алг F(цел n)

нач

  вывод n

  если n >= 5 то

    F(n - 2)

    F(n - 1)

    F(n - 2)

  все

кон

procedure F(n: integer);

begin

  write(n);

  if n >= 5 then

  begin

    F(n - 2);

    F(n - 1);

    F(n - 2)

  end

end;

Си

void F(int n) {

  printf("%d", n);

  if (n >= 5) {

    F(n - 2);

    F(n - 1);

    F(n - 2);

  }

}

Что выведет программа при вызове F(6)? В ответе запишите последовательность выведенных цифр слитно (без пробелов).

Ответы

45

29