OpenFIPI 2.0

8

1

042DDB

Сколько существует десятичных пятизначных чисел, делящихся на 5, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом?

480

from itertools import *
k = 0
for i in permutations('0123456789',r=5):
    s = ''.join(i)
   if int(s)%5==0:
      if s[0]!='0':
         s = s.replace('3','1').replace('5','1') \ .replace('7', '1').replace('9','1') \ .replace('2', '0').replace('4','0') \ .replace('6', '0').replace('8','0')
         if '00' not in s and '11' not in s:
             k+=1
print(k) 

Просмотреть отправленные ответы 042DDB