OpenFIPI 2.0

8

1

01E706

Сколько существует десятичных четырёхзначных чисел, в которых все цифры различны и никакие две чётные или две нечётные цифры не стоят рядом?

720

from itertools import *
k=0
for i in permutations('0123456789', r=4):
    s=''.join(i)
    if s[0] != '0':
        for j in '02468':
            s = s.replace(j,'-')
        for j in '13579':
            s = s.replace(j,'*')
        if '**' not in s and '--' not in s:
            k +=1
print(k,s)

Просмотреть отправленные ответы 01E706